Aug 22 2013

A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse.

I started learning development for Android and downloaded the Eclipse IDE that includes the Android SDK from the Android Development site. Eclipse should be installed after you installed the Java Runtime Environment.

On both my machines I received the below error when starting Eclipse. In my case I think it has to do with the fact that i installed Eclipse and the JRE to D: instead of the default locations in the installers.

eclipse error

 

 

 

 

 

 

 

 

 

I solved this issue by:

1. Right click the Eclipse exe and choose properties.
2. In the Target field add -vm “D:Program FilesJavajdk1.7.0bin” behind the D:adt-bundleadt-bundle-windows-x86_64-20130729eclipseeclipse.exe
3. In essence it should look like your_drive_letter:path to eclipse installationeclipseeclipse.exe -vm “drive_letter_where_JRE_is_installed:Program FilesJavajdk_version_numberbin”
4. Click apply and ok.

Eclipse should now start without any problems.