Dec 17 2015

Exchange 2010 Queue Build up with Event ID 1035

We had an interesting issue with queues building up to remote sites. In queue viewer we noted errors sending mail to different remote sites as per below:

451 4.4.0 Primary Target IP Address responded with: “235 00000xxxxxxxxx”

QueueBuildUpinQueueViewer

And in the Event Viewer we noticed event ID 1035 , MSExchangeTransport

QueueBuildUPEventViewer

At first we thought the issue has to be on the specific Exchange 2010 server trying to send the mail as it was the only server in the DAG that could not send mail to the remote servers. However, the problem was still present after restarting the Hub Transport Service on the server experiencing the above issues.

As a shot in the dark we restarted the SMTP and Hub Transport Services on the remote servers (to where the mail is destined) and the errors disappeared and the mail was sent to the remote servers.


Dec 17 2015

Provisioning Layer initialization failed error when running a cmdlet in Exchange Management Shell

I’ve had the below error a few times this year when trying to open the Exchange Management Shell or running a cmdlet.

ScriptingAgentInitializationFailed

To get this working browse to another Exchange 2010 server and copy the ScriptingAgentConfig.xml file from the working server and paste it in the same directory (as per below) on the non-working server.

The file can be found under your Exchange Installation by default c:\Program Files\Microsoft\Exchange Server\V14\Bin\CmdletExtensionAgents\